Webserver issue

Incident Report for BIMcollab

Resolved

This incident has been resolved, server is reachable again.
Posted Mar 20, 2025 - 14:02 CET

Investigating

There is currently an issue with one of our webservers making it unreachable for the respective customers. We are investigating the issue.
Posted Mar 20, 2025 - 13:44 CET
This incident affected: BIMcollab Nexus.