The issue affecting the visibility of models in the Model tab has been successfully resolved. You should now be able to view all your models as expected.
Posted Jul 14, 2025 - 14:12 CEST
Identified
We’re currently investigating an issue where models are not appearing in the Model tab of your space. Please rest assured that your models are safe and still stored securely on our servers. Our team is actively working to resolve this as quickly as possible, and we’ll update you as soon as the models are visible again.
Posted Jul 14, 2025 - 13:51 CEST
This incident affected: BIMcollab Nexus and BIMcollab Twin.