Upload and download of files slow or unavailable

Incident Report for BIMcollab

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 15:27 CEST

Update

The root cause has been found and a fix has been deployed. We're closely monitoring the systems to see if the issue remains resolved.
Posted Aug 26, 2026 - 15:27 CEST

Update

Our engineers are working on the mitigation of the issue, unfortunately we can not provide timeline of the mitigation yet.
Posted Aug 26, 2026 - 13:09 CEST

Investigating

Customers can experience issues whilst up- or downloading files to the platform. We're currently investigating the cause.
Posted Aug 26, 2026 - 11:27 CEST
This incident affected: BIMcollab Twin.