Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 12, 2025 - 10:30 CEST
Scheduled
We would like to inform you that scheduled maintenance will be performed on our firewalls.
During this period, a brief service interruption may occur, potentially affecting access to all services. We anticipate any disruption to be minimal and short in duration.
Posted Jul 07, 2025 - 14:02 CEST
This scheduled maintenance affected: BIMcollab Nexus, BIMcollab Twin, BIMcollab ID, and BIMcollab Connector.